Skriv et svar: KompoZer / Nvu » Problem med æ, ø og å i php, ved brug af include()

Hvis du skal beskrive et problem, kan et skærmbillede ofte være en god hjælp. Læs evt. guiden Hvordan uploader jeg et billede.

For at hindre automatisk spam, beder vi dig svare på dette simple spørgsmål.
  • :D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
  • BBkode er slået TIL
    [img] er slået TIL
    [flash] er slået FRA
    [url] er slået TIL
    Smilies er slået TIL
Udvidet visning

Emnegennemgang: Problem med æ, ø og å i php, ved brug af include()

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af AlleyKat » ons 19. maj 2010 17:09

Lidt sent, men alligevel:

Kan du evt. ikke bruge HTML-koderne for æøå i stedet i teksten (jeg går ud fra at det drejer sig om statiske tekster)?

Edit: Jeg kan i øvrigt ikke se nogen fejl på siden, så det er nok løst for længst..

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af Jesper Kristensen » lør 8. maj 2010 22:10

Ok, men du skal altså stadig sørge for at de to sider er gemt med samme tegnkodning.

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af Majasol » lør 8. maj 2010 21:44

Og opdagede lige at jeg glemte at skrive navn på (: Den tidligere meddelse er fra mig (:

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af Gæst » lør 8. maj 2010 21:28

Jeg har haft Wordpress (: Det dumme er bare, at jeg ikke er god nok til at finde rundt i WP-koderne, og jeg vil stadig gerne have mulighed for, at kunne lave mine egne layouts, som jeg vil have dem (;

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af Jesper Kristensen » lør 8. maj 2010 21:25

Hvis du bare vil have en blog, hvorfor installerer du ikke bare WordPress? Det er dejligt nemt, og det hele er sørget for.

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af Majasol » lør 8. maj 2010 21:21

Stadig ingen ændringer.

Jesper Kristensen skrev: Edit: Jeg opdagede lige at du har et å i utf-8 nederst på siden. Jeg vil tro du er kommet til at gemme dine to filer (den der inkluderer og den der inkluderes) i to forskellige tegnkodninger. Du er nødt til åbne en af dem og gemme den med den tegnkodning som den anden side bruger, så de begge bruger samme tegnkodning.


Mht. det næste problem, så har jeg slet ikke styr på hvordan selve blog-systemet er bygget op, og jeg kan derfor ikke sætte det i sammen tegnkodning.
Det er noget der kan downloades gratis, og jeg har derfor ingen indflydelse over dens kodning.

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af Jesper Kristensen » lør 8. maj 2010 21:09

Edit: Jeg opdagede lige at du har et å i utf-8 nederst på siden. Jeg vil tro du er kommet til at gemme dine to filer (den der inkluderer og den der inkluderes) i to forskellige tegnkodninger. Du er nødt til åbne en af dem og gemme den med den tegnkodning som den anden side bruger, så de begge bruger samme tegnkodning.

Re: Problem med æ, ø og å i php, ved brug af include()

Indlæg af Jesper Kristensen » lør 8. maj 2010 21:03

Siden er tydeligvis gemt i iso-8859-1, men du har angivet utf-8 i din <meta>. ret det.

Ikke relateret: Du er også kommet til at sætte et ekstra <html> ind før din <!doctype>. Den skal du lige fjerne.

Problem med æ, ø og å i php, ved brug af include()

Indlæg af Majasol » lør 8. maj 2010 20:54

http://alizay.dk

Det er sikkert et meget spurgt spørgsmål, men jeg har et problem med at skulle bruge æ, ø og å i PHP, når jeg bruger include().
Jeg har forsøgt mig med både utf8 og iso859-1, og jeg er helt tom for ideer.

Nogle som kan give mig en løsning på problemet? (;

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US) AppleWebKit/532.5 (KHTML, like Gecko) Chrome/4.1.249.1064 Safari/532.5