Thunderbird & Lightning » Mailkopier i kladdemappe slettes ikke ved afsendelse

ojunker
 
Indlæg: 343
Tilmeldt: tirs 9. mar 2010 00:37
Geografisk sted: Aarhus

Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf ojunker » man 19. nov 2018 15:56

Hej
I Thunderbirds Indstillinger->Redigering gemmer jeg automatisk en mailkopi hvert 5. minut.
Efter opdateringen til version 60.3 opdager jeg, at gemte kopier i Kladdemappen ikke slettes, når mailen afsendes. Det sker naturligvis kun i de situationer, hvor jeg er lidt længe om et redigere mailen, altså over 5. minutter.
Det forekommer kun for POP3 konti, som alle refererer til Kladdemappen under Lokale mapper.
For mine IMAP konti, som alle har deres egen Kladdemappe, slettes mailkopier som hidtil automatisk, når mailen afsendes. Her er ingen problemer.
Jeg har søgt på, om andre har rapporteret problemet. Jeg kan kun finde rapporter herom, som ligger nogle år tilbage. Det kan jo næppe vedrøre version 60.3.
Det er muligt, at min søgning ikke har være grundig nok.

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:63.0) Gecko/20100101 Firefox/63.0
Mvh. Ole

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 5171
Tilmeldt: fre 28. dec 2007 16:40
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf Jørgen Rasmussen » man 19. nov 2018 19:39

Hej Ole

Jeg kan ikke genskabe dit problem. Men jeg har heller ikke haft version 60.0 installeret. Min Thunderbird blev automatisk opdateret til version 60.3.0 og senere til 60.3.1.
Jeg tror dit problem er dét, der nævnes i udgivelsesnoterne for version 60.3.0 - som værende løst:
"Saving content of Write windows didn't overwrite existing file": https://www.thunderbird.net/en-US/thund ... easenotes/
Det vil have lavet en ny kladde hvert 5. minut. Kun den seneste kladde ville blive slettet, når du sendte mailen. De resterende kladder ville blive liggende i mappen Kladder.
Er du sikker på, at problemet ikke forsvandt med opdateringen til version 60.3.0?
Hilsen Jørgen

ojunker
 
Indlæg: 343
Tilmeldt: tirs 9. mar 2010 00:37
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf ojunker » man 19. nov 2018 22:35

Hej Jørgen
Jeg har haft version 60 installeret i ganske få minutter, men da jeg opdagede, at det ikke var en opdateringsversion, geninstallerede jeg øjeblikkeligt version 52.9.1.
Den 31. oktober blev version 60.3 installeret automatisk, og i dag kører jeg også 60.3.1.
Jeg har ikke tidligere registreret problemet, og jeg har først bemærket det efter installationen af v. 60.3.
Det undrer mig også, at det kun er kladdemappen under Lokale mapper, der har problemet.
I dag havde jeg 4 kopier liggende i kladder, og der lå også 4, efter at mailen var afsendt.
Det er jo ikke noget alvorligt problem. Jeg kan jo minimere det enten ved at være lidt hurtigere i vendingen, eller ved at sætte tiden op til f.eks.10 minutter.
Mvh. Ole

ojunker
 
Indlæg: 343
Tilmeldt: tirs 9. mar 2010 00:37
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf ojunker » tirs 20. nov 2018 10:22

Hej Jørgen
En tilføjelse, som lige skulle graves frem af hukommelsen!
I starten af oktober måned undersøgte jeg om den planlagte opdateringsversion 60.1.0 var tilgængelig. Her viste det sig, at planlagte v.60.1.0 og v.60.2.0 begge var blevet skippet. Til gengæld lå der en opdateringsversion 60.2.1 klar.
Jeg kunne ikke fremtvinge opdatering via Thunderbird og hentede den derfor manuelt.
V.60.2.1 virkede upåklageligt. Til min undren fremgår versionen ikke af opdateringshistorikken.
Men jeg har altså opdateret automatisk til 60.3.0 fra 60.2.1.
Kan det mon have betydning for Kladdemappe problemet?
Mvh. Ole

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11816
Tilmeldt: lør 5. mar 2005 21:45

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf Kim Ludvigsen » tirs 20. nov 2018 17:05

Hej Ole

Apropos hukommelse, så kommer jeg i tanke om, at jeg har haft et lignende problem for længe siden. Dengang var problemet vist, at forbindelsen var til nettet var ustabil, så vidt jeg husker, fik jeg samtidig en masse advarsler om, at kladden ikke kunne gemmes. Dem, der blev gemt, blev så ikke efterfølgende slettet.

Men det er nogle år siden, så det er ikke sikkert, det er det samme, om driller dig.
Mvh. Kim

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 5171
Tilmeldt: fre 28. dec 2007 16:40
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf Jørgen Rasmussen » tirs 20. nov 2018 17:40

Jeg ved ikke, hvorfor du har problemer med kladder, der ikke slettes. Men måske er en af filerne, der holder styr på eller indeholder kladderne, beskadiget. Du kan først prøve at reparere den pågældende kladde-mappe:
Højreklik på mappen og vælg Egenskaber. Klik på knappen 'Reparer mappe'.

Hvis det ikke hjælper, kan du prøve at slette filerne Drafts og Drafts.msf. (Flyt først indholdet af mappen Kladder til en anden mappe, hvis den indeholder noget, du vil gemme). Du finder filerne sådan: Klik på menuknappen, peg på 'Hjælp', og klik så på 'Teknisk information'. Klik på knappen 'Åbn mappe' i afsnittet Programinfo. Afslut Thunderbird. Åbn så mappen Mail i mappen, du lige åbnede. Åbn mappen Local Folders. Slet filere Drafts og Drafts.msf. Når du har startet Thunderbird igen, kan du oprette en ny Kladde-mappe:
Højreklik på 'Lokale mapper' i mapperuden og vælg 'Ny mappe'. Giv den navnet Drafts.

Så vidt jeg husker, viser opdateringshistorikken kun opdateringer, Thunderbird har foretaget. Hvis du opdaterer ved at hente og installerer Thunderbird manuelt, vil det derfor ikke fremgå af opdateringshistorikken.
Hilsen Jørgen

ojunker
 
Indlæg: 343
Tilmeldt: tirs 9. mar 2010 00:37
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf ojunker » tirs 20. nov 2018 22:29

Reparation af Kladde-mappen ændrede ingenting.
Herefter slettede jeg Drafts og Drafts.msf og oprettede efterfølgende Kladde-mappen påny.
Ny test af mailafsendelse. Kladderne blev ikke slettet ved afsendelse.
Indholdet i Drafts filen var voldsomt. Det skyldtes tilsyneladende, at jeg utilsigtet havde signeret mailen digitalt.
Herefter slettede jeg kladdefilerne manuelt. (I Thunderbird)

Jeg gentog så forsøget. Denne gang uden at mailen blev signeret digitalt.
Og nu fulgte jeg med i, hvad der skete med filerne i min File manager.
Det så meget normalt ud, synes jeg.
Kladde filerne blev stadigvæk ikke slettet automatisk.
Herefter slettede jeg igen kladdefilerne manuelt.

Jeg har nu set på Drafts filen igen. Den er på 145 KB.
Der ligger mindst et par hundrede linier "snavs" i den.
Hvor kommer det fra, når Draft filen var slettet?

Kan det tænkes, at hvis der i den mail, man besvarer, eller den ny mail man redigerer, er indkopieret tekst fra et Word dokument, så indkopierer man også en masse formaterings snavs, som ikke er synlig i mailteksten?
Mvh. Ole

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 5171
Tilmeldt: fre 28. dec 2007 16:40
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf Jørgen Rasmussen » ons 21. nov 2018 20:53

Jeg har nu set på Drafts filen igen. Den er på 145 KB.
Der ligger mindst et par hundrede linier "snavs" i den.
Hvor kommer det fra, når Draft filen var slettet?

Når du sletter en meddelelse i en mappe, slettes meddelelsen reelt ikke. Den markeres bare til sletning. Først når du har optimeret mappen, slettes meddelelsen fra filen. Derfor vil filen være større end 0 KB, indtil mappen er blevet optimeret.

Kan det tænkes, at hvis der i den mail, man besvarer, eller den ny mail man redigerer, er indkopieret tekst fra et Word dokument, så indkopierer man også en masse formaterings snavs, som ikke er synlig i mailteksten?

Ja.

Har du testet, om problemet også er der, når du kører Thunderbird i fejlsikret tilstand?
Hilsen Jørgen

ojunker
 
Indlæg: 343
Tilmeldt: tirs 9. mar 2010 00:37
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf ojunker » ons 21. nov 2018 22:15

Problemet er der også i fejlsikret tilstand.
Allerede i går aftes fjernede jeg fluebenet i indstillinger, så der ikke automatisk gemmes kladder.
Jeg ser det ikke som et alvorligt problem, så den indstilling kører jeg med indtil videre.
Så vil jeg undersøge, om noget ændrer sig i forbindelse med kommende opdateringer.
Mvh. Ole

ojunker
 
Indlæg: 343
Tilmeldt: tirs 9. mar 2010 00:37
Geografisk sted: Aarhus

Re: Mailkopier i kladdemappe slettes ikke ved afsendelse

Indlægaf ojunker » ons 21. nov 2018 23:24

Problemet forekommer ikke på min bærbare.
Den bærbare er anskaffet i maj 2017 og er nyere end den stationære.
Opsætningen af Thunderbird er den samme på begge maskiner.
I forbindelse med installationen af Thunderbird på den bærbare kopierede jeg indholdet af Thunderbirds profilmappe fra den stationære til profilmappen på den bærbare.
Kontoopsætningen er nøjagtigt ens, men indholdet i mapperne under lokaler mapper er naturligvis ikke længere helt den samme.
Mvh. Ole