KompoZer / Nvu » store billeder a la popup

mettem
 
Indlæg: 1
Tilmeldt: tors 7. nov 2013 11:04

store billeder a la popup

Indlægaf mettem » tors 7. nov 2013 11:13

Hej

Jeg har nogle små billeder på min hjemmeside og vil gerne vise dem i stor størrelse. Jeg har lavet en side med det store billede og linket til det fra det lille billede. Det virker fint hvis jeg siger vis i browser, men det tager ikke siden med når jeg siger overfør som
Er der nogle der kan hjælpe?

VH
Mette

Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.1; Trident/6.0; MAMD)

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11226
Tilmeldt: lør 5. mar 2005 21:45

Re: store billeder a la popup

Indlægaf Kim Ludvigsen » tors 7. nov 2013 13:05

Er det når du ser siden i KompoZer? Du kan ikke regne med funktionerne for hjemmesiden, når du ser den i KompoZer, fordi det er en editor.

For at kunne bruge en sides funktioner (links m.m.), skal du se siden i en browser. Hvis det også driller i en browser, så fortæl lidt nærmere, hvad du mener. Det vil gøre det nemmere at hjælpe dig, hvis du har mulighed for at lægge siden ud på internettet og give os et link til den.
Mvh. Kim

scootergrisen
 
Indlæg: 442
Tilmeldt: lør 29. okt 2011 21:57

Re: store billeder a la popup

Indlægaf scootergrisen » lør 9. nov 2013 09:34


Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11226
Tilmeldt: lør 5. mar 2005 21:45

Re: store billeder a la popup

Indlægaf Kim Ludvigsen » lør 9. nov 2013 10:21

Nu fik jeg lige læst det første indlæg igen i en lidt mere vågen tilstand, og jeg tror, jeg har forstået problemet.

Mette, du skal overføre hver side for sig. KompoZer overfører kun den aktuelle side. Så du skal altså overføre siden med de små billeder, herefter skal du indlæse siden med det store billede i KompoZer og så også overføre den.

Alternativt kan du bruge et FTP-program til at overføre filer, eller du kan overføre ved hjælp af et netværksplacering, som beskrevet på denne side:
http://kimludvigsen.dk/programmer-inter ... .php#mappe
Mvh. Kim

Gæst
 

Re: store billeder a la popup

Indlægaf Gæst » man 11. nov 2013 10:03

Hej Kim

Tak for svar.
Min hjemmeside kan du se på http://www.julemejeriet.dk
De små billeder ligger der nu, men programmet vil ikke overføre de store billeder. Under adventsting kan du se hvad jeg har lavet.
Jeg bruger et ftp program til at overføre det med men det driller lidt. Nogen gange kommer den med en 425 fejl.
Jeg har linket til et stort billede og jeg har også prøvet at lave en rigtig side hvor billedet ligger på, men det driller!
Når jeg har lavet ændringer siger jeg gem som og overfører derefter hver side for sig

Mette

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11226
Tilmeldt: lør 5. mar 2005 21:45

Re: store billeder a la popup

Indlægaf Kim Ludvigsen » man 11. nov 2013 10:49

Ok, du linker direkte til et stort billede og ikke til en side, som jeg troede. Du kan ikke bruge KompoZer til at overføre de store billeder, fordi de ikke ligger på en side, som du har lavet i KompoZer. Du skal derfor bruge et FTP-program eller en netværksplacering.

Hvilket FTP-program har du brugt? Du kan evt. prøve at bruge en netværksplacering som beskrevet på det tidligere bragte link, så bør du ikke få en fejl.

Men, inden du overfører, så er der noget, du bør rette - og det kan faktisk være en af grundene til, at det driller med at få overført og vist billederne. Du benytter mellemrum i filnavnene. Ret filnavnene - og husk også at rette linkene på siden - så der ikke er mellemrum. Brug i stedet bindestreg.

Altså, i stedet for fx "stager stor.jpg", så kald filen "stager-stor.jpg". Dette gælder også de små udgaver af billederne.
Mvh. Kim

Gæst
 

Re: store billeder a la popup

Indlægaf Gæst » man 11. nov 2013 12:50

Hej igen

Jeg linker til en html side men det virker stadig ikke.
Jeg har bare lavet en side med kun det store billede på. Det er gemt som og overført som.
Jeg kan se i kilden at taget er _blank, så jeg ved ikke om det er derfor.
Jeg bruger ftp program fra one.com ( ved ikke om det er det du spørger om )
På brugskunst siden har jeg et andet problem. jeg kan ikke få fjernet den tekst ( stort billede HER ) jeg har skrevet nedenunder fad.
Når jeg åbner filen i komposer kan jeg ikke se teksten, men den er der stadig på nettet. Jeg har gemt som og overført som uden teksten flere gange

ps. er igang med at rette filnavnene med bindestreg og det er gjort på brugskunst siden. Og det er også her jeg har prøvet at linke til en html side ( det 1. billede med et fad)

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11226
Tilmeldt: lør 5. mar 2005 21:45

Re: store billeder a la popup

Indlægaf Kim Ludvigsen » man 11. nov 2013 19:18

Du har flere problemer, og jeg er ikke sikker på, at jeg forstår dem alle. Det kan sikkert virke meget uoverskueligt i øjeblikket, men tag det roligt, og koncentrér dig om ét problem ad gangen.

Med hensyn til siden med det store fad på brugskunstsiden, så har du indsat linket forkert. Du linker til en fil på din egen computer i stedet for til filen på webserveren.

Prøv at holde musen hen over det lille billede, så vil du i browserens statuslinje se, at det linker til:
file:///C:/Users/mette/Desktop/julemejeriet/storfad.html
"file:///" henviser til en fil på din computer i stedet for en fil på webserveren. Det skyldes, at du har fået indsat linket forkert. Når du indsætter linket, skal du skrive "storfad.html" som linkplacering, og du skal om muligt have flueben ud for "Relativ URL".

Du fortæller, at der står "_blank" i koden. Det vil få siden til at åbne sig i et nyt vindue eller i et nyt faneblad. Så det skal du ikke have. Fjern fluebenet ud for "Link skal åbnes", når du indsætter et link.

Du har ikke fået overført filen storfad.html, så du må have brugt FTP-programmet forkert. Er det One.coms Web file manager, du har brugt?
Altså det som de skriver om her:
http://www.one.com/da/support/guide/bru ... troduction

Du skriver, at du ikke kan få fjernet en tekst under fad på brugskunstsiden. Jeg er ikke klar over, hvilken tekst du tænker på. Jeg kan ikke se en tekst på den side, udover den over billederne.

Start med at få overført "storfad.html" til webhotellet. Uanset om du bruger et FTP-program eller One.coms Web file manager, så skulle du i programmet gerne kunne se filen ligge på serveren efter overførslen.

Ret herefter linket og overfør den rettede side til serveren.
Mvh. Kim

Gæst
 

Re: store billeder a la popup

Indlægaf Gæst » tirs 12. nov 2013 07:44

Hej Kim

Mange tak for din hjælp.
Jeg har nu brugt file manageren i one.com til at oploade filerne med og nu kommer de store billeder frem.
Jeg havde ikke fundet ud af det uden din hjælp, så jeg håber ikke du har brugt alt for meget tid på mig, men endnu engang tak, og jeg vender sikkert tilbage igen

Mette

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11226
Tilmeldt: lør 5. mar 2005 21:45

Re: store billeder a la popup

Indlægaf Kim Ludvigsen » tirs 12. nov 2013 09:18

Du har stadig et problem, og det skyldes måske en fejl i KompoZer. Baggrundsbilledet kommer ikke med, for i stedet for at henvise til en fil på webserveren, henvises til filen på din computer.

Du har flere muligheder:

Du kan rette fejlen, så baggrundsbilledet vises.

Du kan nøjes med at linke til selve den store udgave af billedet i stedet for at lave en side med billedet. Resultatet vil blive det samme for den besøgende som i øjeblikket, og du sparer lidt arbejde.

Den tredje mulighed vil gøre din side en hel del smartere, men den er også mere nørdet. Du kan bruge en funktion til at vise en pop op, som fx den scootergrisen henviser til i et tidligere indlæg. Ulempen er, at du skal rode med kode, men resultatet bliver meget bedre.

Selvom det kan virke nørdet at skulle rode med kode, så er det faktisk ikke så svært, når du har prøvet det et par gange. Siden ovenfor indeholder en forklaring på engelsk, men du kan også få hjælp her.

Mit forslag:
Lav linkene direkte til billederne i stedet for til html-filer, og upload billederne ved hjælp af One.coms filmanager. Når du er færdig, og siden virker, kan du vurdere, om du vil bruge mere tid på projektet. Men det vil være forholdsvis nemt at lave de nødvendige ændringer for at få scootergrisens pop op-billeder til at virke. Du skal blot ind i kodevisning i KompoZer og indsætte lidt ekstra kode.
Mvh. Kim

Gæst
 

Re: store billeder a la popup

Indlægaf Gæst » ons 4. dec 2013 12:16

Hej Kim

Jeg havde slet ikke set at du havde skrevet mere, har ikke haft tid.
Men nu har jeg et andet problem. Jeg indsatte en video, og derefter kunne jeg ikke åbne komposer. Der kom et lille billede hvor den bad mig om at oprette en ny profil. Jeg kunne kun vælge en default bruger.
jeg var så dum at oprette en ny profil og nu kan jeg ikke rette i indeksfilen, og som du kan se så virker videoen men den har fjernet alle mine billeder. Alle de andre sider virker.
Jeg har lavet 2 hjemmesider i komposer og nu kan jeg ikke se mine 2 hjemmesider i site manageren.
Jeg ved ikke hvordan jeg kommer tilbage til min tidligere profil.

VH
Mette

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11226
Tilmeldt: lør 5. mar 2005 21:45

Re: store billeder a la popup

Indlægaf Kim Ludvigsen » tors 5. dec 2013 06:32

Gæst skrev: Hej Kim

Jeg havde slet ikke set at du havde skrevet mere, har ikke haft tid.
Men nu har jeg et andet problem. Jeg indsatte en video, og derefter kunne jeg ikke åbne komposer. Der kom et lille billede hvor den bad mig om at oprette en ny profil. Jeg kunne kun vælge en default bruger.
jeg var så dum at oprette en ny profil og nu kan jeg ikke rette i indeksfilen, og som du kan se så virker videoen men den har fjernet alle mine billeder. Alle de andre sider virker.


Jeg ved ikke, hvad der er sket med profilen, men det er ikke på grund af videoen. Og du skulle gerne stadig kunne rette i indeksfilen. En ny profil vil ikke forhindre redigering, den vil blot betyde, at dine indstillinger og oplysninger - fx adgangskode til serveren - glemmes, så du skal indtaste oplysninger/ændre indstillinger igen. Det er også derfor, du ikke kan se dine sider i sitemanageren.

Sådan får du din gamle profil tilbage:
Luk KompoZer
Højreklik på genvejen til KompoZer og vælg Egenskaber
Næste punkt kan være lidt forskelligt alt efter version af Windows, og jeg ved ikke, hvordan det er i din. Men i vinduet med egenskaber, skal du finde feltet med stien til programmet, den ligner dette:
C:\EN STI\KompoZer\kompozer.exe
Du skal nu indsætte " -p" sidst i feltet, så det kommer til at se sådan ud:
C:\EN STI\KompoZer\kompozer.exe -p
Klik på OK for at gemme ændringen og lukke vinduet
Dobbeltklik på genvejen
Markér default og klik på Start KompoZer.
Nu skulle du gerne have den gamle profil tilbage
Du skal efterfølgende ind og fjerne " -p" igen, ellers får du vist valgboksen hver gang du starter kompoZer.


Med hensyn til billederne:
Problemet er, at du har fået indsat billederne forkert på den ikke-virkende side. Du har angivet dem til at ligge i en undermappe med navnet images - ligesom du har på din egen computer - men på webserveren ligger de i samme mappe som HTML-filen.

Enten skal du oprette en mappe på webserveren med navnet images, hvor du så skal kopiere blomst7.png, ranke.png, bar37.gif og de andre billeder på siden over i, eller du skal rette de enkelte billedadresser, så de fx hedder blomt7.png i stedet for images/blomst7.png.

Når du fremover indsætter billeder, så skal du huske, at placeringen skal være den samme på din egen computer som på serveren.
Mvh. Kim

Gæst
 

Re: store billeder a la popup

Indlægaf Gæst » tors 5. dec 2013 08:24

Hej Kim

Tusind tak for hjælpen. Det virker igen.
Jeg har lært på SDE at man skal lave en mappe med alle billederne, de måtte ikke ligge sammen med HTML filerne. Men det kan jeg godt se skal laves om.
Er der et sted hvor jeg kan honorere dig for alt din hjælp?

VH
Mette

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11226
Tilmeldt: lør 5. mar 2005 21:45

Re: store billeder a la popup

Indlægaf Kim Ludvigsen » tors 5. dec 2013 09:07

Det kan gøre det mere overskueligt at placere billederne for sig selv, især hvis man har mange sider og mange billeder. Men når man ikke har så mange - som i dit tilfælde - er det nemmest bare at have det hele i en enkelt mappe.

Med hensyn til honorering, så er det ikke noget, du skal tænke på.

Redigeret: Jeg har fjernet lidt tekst, som jeg skrev, fordi jeg tog fejl af, hvilket forum jeg skrev i.
Mvh. Kim