KompoZer / Nvu » hjemmeside med Kompozer "portsdunord.com" får mærkelig kode

capall
 

hjemmeside med Kompozer "portsdunord.com" får mærkelig kode

Indlægaf capall » man 30. jun 2014 10:11

Hej, siden er fra 2007, og bliver jævnligt opdateret. Men nu sker der underlige ting! En side har jeg ændret og sat "ankre" på til nye interne links. Ved kontrol af et anker næste dag ser jeg, at der er kommet et ekstra ved siden af. Og det er tilfældet ved dem alle. Ved eftersyn i link location er der en rad af ankernavne i coder mrk mrk <#MOZtoLCD... med flercifrede tal efter ..> til samme links?
Det er ikke sket før.
Er der nogen som ved noget?
mvh caphaugaard

Mozilla/5.0 (X11; Linux x86_64; rv:30.0) Gecko/20100101 Firefox/30.0

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11159
Tilmeldt: lør 5. mar 2005 22:45

Re: hjemmeside med Kompozer "portsdunord.com" får mærkelig k

Indlægaf Kim Ludvigsen » man 30. jun 2014 11:15

Jeg vil meget gerne se, hvordan det ser ud, men jeg kan ikke umiddelbart finde et eksempel på din side. Kan du fortælle på hvilken side, du oplever det, og beskriv gerne nøjagtigt, hvor jeg kan se det.

Fortæl også lige, om det er noget du ser i koden, eller om det ses på selve siden, og også om det interne link stadig virker.
Mvh. Kim

capall
 

Re: hjemmeside med Kompozer "portsdunord.com" får mærkelig k

Indlægaf capall » tirs 1. jul 2014 10:58

Hej Kim, desværre, jeg slettede skidtet, fordi det var kun på kladden. Jeg havde sat et "anker" til hvert link, og dagen efter stod der pludselig ikke eet men to ankre ved hvert link. Da jeg tjekkede de nye tilkomne ankre i "Link Location" stod de med koderne #MOZTOLCD...... med forskellige 6-cifrede tal efter - i en lodret række efter mine egne. Mine egne links virkede OK stadigvæk, mens de andre aktiverede jeg ikke, men slettede dem.
Så gik jeg på Google og manipulerede med koden der, og fandt en side, hvor denne kode optrådte igen hos En, der også anvendte Kompozer og havde problemer her. Men spørg mig ikke, hvad det var for en side! Den smuttede!
Og den mystiske kode er jeg ikke faldet over igen
mvh caphaugaard

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11159
Tilmeldt: lør 5. mar 2005 22:45

Re: hjemmeside med Kompozer "portsdunord.com" får mærkelig k

Indlægaf Kim Ludvigsen » tirs 1. jul 2014 11:28

Vend tilbage, hvis du oplever det igen. Uden at se siden og koderne kan jeg kun gætte, og mit gæt er, at du har oprettet linkene som overskrifter. KompoZer kan selv oprette ankre på overskrifter, og de får i nogle tilfælde formatet mozToc efterfulgt af tal.

Prøv på en testside at oprette et par overskrifter.
Opret et link et almindeligt andet sted på siden via linkknappen.
Klik på rullemenuen ud for linkplacering, og du vil her se, at KompoZer har oprettet ankre til de enkelte overskrifter.

Ankrene indsættes ikke i koden, før man vælger dem som et link via rullemenuen i linkboksen, og de kan ikke se på den færdige side, undtagen i form af de links, man har oprettet.
Mvh. Kim

capall
 

Re: hjemmeside med Kompozer "portsdunord.com" får mærkelig k

Indlægaf capall » tirs 1. jul 2014 20:12

Tak Kim, det svar med link på overskrifter i Kompozer - var lige netop hvad det var!
Gåden er løst- mvh caphaugaard