KompoZer / Nvu » Fejl i 'Knap'

jessie-peter
 
Indlæg: 3
Tilmeldt: lør 11. jun 2005 09:59
Geografisk sted: Korsør

Fejl i 'Knap'

Indlægaf jessie-peter » lør 11. jun 2005 10:11

Jeg er helt nybegynder ud i web-design, så prøver man sig frem.

En komponent jeg har prøvet er 'Knap', men den er godt nok lille.
Er det mig som er dum eller er der fejl i programmet
Peter L

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11702
Tilmeldt: lør 5. mar 2005 22:45

Re: Fejl i 'Knap'

Indlægaf Kim Ludvigsen » lør 11. jun 2005 14:52

jessie-peter skrev: Jeg er helt nybegynder ud i web-design, så prøver man sig frem.

En komponent jeg har prøvet er 'Knap', men den er godt nok lille.
Er det mig som er dum eller er der fejl i programmet


Det kunne godt se ud som en mindre hensigtsmæssig egenskab ved programmet. Problemet er, at der ikke er fastsat en størrelse på knappen, og i stedet for at vælge en almindelig størrelse, vælger Nvu åbenbart den mindst mulige størrelse.

Marker knappen (du skal muligvis højreklikke på den for at få den markeret), og du vil se, at <button> i statuslinjen nederst i programmet bliver hvid. Højreklik på <button>, og vælg Indline stil og derefter Boks-egenskaber.

Du kan nu vælge en passende bredde og højde på knappen i rullemenuerne ved at skrive et tal. Klik derefter på rulned-knappen til højre for tallet, og vælg, hvilken enhed tallet skal være i, for eksempel px.

Der er muligvis endnu et problem, for jeg får ingen tekst på knappen, men det skyldes måske, at jeg sidder med en ældre version af Nvu.
Mvh. Kim

jessie-peter
 
Indlæg: 3
Tilmeldt: lør 11. jun 2005 09:59
Geografisk sted: Korsør

Re: Fejl i 'Knap'

Indlægaf jessie-peter » lør 11. jun 2005 18:43

Hej Kim

Tak for svaret det er ganske imponerende, hvad man kan i forhold til den gl. Frontpage jeg prøvede med for mange år siden.

.....meeen
"Der er muligvis endnu et problem, for jeg får ingen tekst på knappen, men det skyldes måske, at jeg sidder med en ældre version af Nvu."

Det kan jeg godt gi' dig ret i, for jeg kan heller ikke få tekst på knappen - det må vidst være en 'hovsa' - :D . I øvrigt har jeg ikke kunnet finde det sted, hvor man kan skrive teksten på knappen - kan du ???.
Peter L

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11702
Tilmeldt: lør 5. mar 2005 22:45

Re: Fejl i 'Knap'

Indlægaf Kim Ludvigsen » lør 11. jun 2005 20:01

jessie-peter skrev: Det kan jeg godt gi' dig ret i, for jeg kan heller ikke få tekst på knappen - det må vidst være en 'hovsa' - :D . I øvrigt har jeg ikke kunnet finde det sted, hvor man kan skrive teksten på knappen - kan du ???.


Du kan navngive den ved at skrive mellem <button> og </button> i kildekodevisningen - jeg ved ikke, hvordan det gøres i normal-visningen.

Og dog - lige et vildt gæt, og det virker sør'me:
Skriv teksten, der skal stå på knappen (der hvor knappen skal placeres). Marker teksten, og indsæt så en knap - voila!
Mvh. Kim

jessie-peter
 
Indlæg: 3
Tilmeldt: lør 11. jun 2005 09:59
Geografisk sted: Korsør

Re: Fejl i 'Knap'

Indlægaf jessie-peter » lør 11. jun 2005 20:35

"Skriv teksten, der skal stå på knappen (der hvor knappen skal placeres). Marker teksten, og indsæt så en knap - voila![/quote]"

Du har ret, men det er dog en 'klumpe-dumpe' måde, mon ikke de har glemt feltet, for så kan man jo lige så godt skrive hele kildekoden selv :mrgreen: .
Peter L

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11702
Tilmeldt: lør 5. mar 2005 22:45

Re: Fejl i 'Knap'

Indlægaf Kim Ludvigsen » lør 11. jun 2005 21:17

jessie-peter skrev: Du har ret, men det er dog en 'klumpe-dumpe' måde, mon ikke de har glemt feltet, for så kan man jo lige så godt skrive hele kildekoden selv :mrgreen: .


Enig, men måske det er os, der prøver noget forkert?

Nu ved jeg ikke, hvad du vil med knappen, men hvis du for eksempel vil lave en send-knap, så prøv følgende:
Klik på Indsæt -> Formular -> Formularfelt. Vælg Udfør-knap i rullemenuen under Felttype, og udfyld Feltnavn og Feltværdi - feltværdien er det som kommer til at stå på knappen.
Mvh. Kim