KompoZer / Nvu » w3c-validering

flemmings
 

w3c-validering

Indlægaf flemmings » tirs 27. jul 2010 16:23

Jeg plejer uden problemer at kunne W3C-validere min hjemmeside http://www.mardi.dk, når jeg har lavet ændringer, men i dag ser http://validator.w3.org/ anderledes ud, end den plejer. Er det en teknisk fejl, for åbenbart får jeg samme "fejl", når jeg prøver at validere andre sider med W3C-mærket.

Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; SLCC1; .NET CLR 2.0.50727; Media Center PC 5.0; .NET CLR 3.5.30729)

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11733
Tilmeldt: lør 5. mar 2005 22:45

Re: w3c-validering

Indlægaf Kim Ludvigsen » tirs 27. jul 2010 17:22

Validatoren ser ud som normalt her, og din side validerer fint (ingen fejl).
Mvh. Kim

Jesper Kristensen
MozillaDanmark
 
Indlæg: 6520
Tilmeldt: lør 26. feb 2005 12:27
Geografisk sted: København

Re: w3c-validering

Indlægaf Jesper Kristensen » tirs 27. jul 2010 18:11

Du kan også prøve at validere med http://validator.nu/ som nogle gange kan finde andre og mere relevante fejl, da den er baseret på den nyere HTML5. Dog kan den også af og til bryde sammen og undlade at give dig et resultat, da den ikke er helt færdiglavet.

flemmings
 

Re: w3c-validering

Indlægaf flemmings » tirs 27. jul 2010 20:16

Det problem, som i dag er opstået, er følgende:

Når jeg på http://mardi.dk
går ned og klikker på W3C HTML4.01-ikonet nederst på siden, bliver jeg sendt til:

http://validator.w3.org/

i stedet for som sædvanlig: http://validator.w3.org/check?uri=http% ... ne&group=0

Men hvis jeg klikker på W3C CSS-ikonet derunder, kommer jeg det sædvanlige sted hen, nemlig
http://jigsaw.w3.org/css-validator/vali ... ardi.dk%2F

flemmings
 

Re: w3c-validering

Indlægaf flemmings » tirs 27. jul 2010 20:25

Måske udtrykker jeg mig lidt uklart, men når jeg klikker på ikonet, kommer jeg ind på http://validator.w3.org/ i stedet for den sædvanlige side, som fortæller, at valideringen er "passed".

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11733
Tilmeldt: lør 5. mar 2005 22:45

Re: w3c-validering

Indlægaf Kim Ludvigsen » tirs 27. jul 2010 21:23

Nåh, sådan. Jeg ved ikke ,om de har lavet om, men adressen er lidt anderledes i deres knap nu end den er på din side. Prøv at udskifte linkadressen:
http://validator.w3.org/check/referer
med:
http://validator.w3.org/check?uri=referer

Den samlede knap-kode:
<a href="http://validator.w3.org/check?uri=referer"><img src="http://www.w3.org/Icons/valid-html401" alt="Valid HTML 4.01 Transitional" height="31" width="88"></a>
Mvh. Kim

flemmings
 

Re: w3c-validering

Indlægaf flemmings » tirs 27. jul 2010 22:39

Mystisk - efter den lille kodeændring på alle sider virker det igen. Tak for hjælpen.

flemmings
 

Re: w3c-validering

Indlægaf flemmings » tirs 27. jul 2010 22:42

Ja, nu kiggede jeg efter på deres webside. De har af en eller anden grund ændret koden. Men ikke for CSS-valideringen!!