KompoZer / Nvu » Nyt spørgsmål

ezstreet
 

Nyt spørgsmål

Indlægaf ezstreet » ons 4. aug 2010 22:10

Hej igen.

Jeg har fået en ny idé om den kan lykkes i KompoZer ved jeg ikke, derfor spørger jeg.

Jeg vil gerne lave en hjemmeside hvor den er delt op i sektioner det skal være sådan at på forsiden er der fx 2 billeder det ene med fisk og den anden med fiskeudstyr, så kan man så trykke på billederne og så kommer man ind til den sektion sådan at man vælger hvad man helst vil se..

Ligesom denne side: http://www.dino.dk/


Mange Hilsner Mike

Mozilla/5.0 (Windows; U; Windows NT 5.1; da; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 (.NET CLR 3.5.30729)

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » ons 4. aug 2010 22:28

Det er desværre ikke muligt at lave det i KompoZer - medmindre man har styr på koderne, så man selv kan lave det i kildekodevisning. Det er muligt at lave koden i et andet program, hvorefter man kan indsætte koden i KompoZer. Det er dog stadig lidt nørdet.

Populært sagt, så inddeler man billedet i flere dele ved at angive koordinater, og man kan så angive links for hvert koordinatsæt.

Det kan se smart ud, men der mindst én grund til at tænke sig om en ekstra gang: Google og andre søgetjenester har ikke rigtigt noget at indeksere på forsiden. Desuden er jeg ikke så sikker på, at det vil virke med en skærmlæser, hvis en blind skulle komme forbi siden.
Mvh. Kim

bnxit
 
Indlæg: 54
Tilmeldt: man 17. maj 2010 20:03

Re: Nyt spørgsmål

Indlægaf bnxit » tors 5. aug 2010 13:00

Mike!
Du foreslår en side med 2 billeder, men websiden du henviser til består faktisk kun af 1 billede.

http://dino.dk/fileadmin/design/grafik/ ... rsiden.jpg

Hvis du vil have 2 billede med hver sit link, er det meget lettere at lave.

mvh.
Bent

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » man 9. aug 2010 20:48

Hej med jer igen.

Jeg har fundet ud af at jeg vil lave min hjemmeside med 1-1-2-1-rund-alternativ, som jeg også startede ud med.

Jeg har flere spørgsmål nogle af dem kan jeg sikkert få af vide i manualen, men jeg har simpelthen ikke tid til at læse den nu når jeg er startet i skole igen osv.

Nu har jeg så lavet plads til flere menupunkter, men der hvor at jeg så har gjort plads til flere er baggrunden bplevet hvid hvordan ændrer jeg den til grå og hvordan laver jeg flere menupunkter/menusider?

Og så til sidst vil jeg spørge om hvad man gør når man vil have et fotoalbum???


På forhånd tusind tak!

/Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » tirs 10. aug 2010 08:48

Har du mulighed for at lægge en prøveside ud på nettet? Det er meget nemmere at hjælpe, når vi kan se problemet og sidens kode.

Jeg forstår ikke, hvad du mener med flere menupunkter/menusider.

Der er mange måder at lave fotoalbum på. Du kan fx bruge et færdigt program som JAlbum, der kan lave mange forskellige flotte albums. Jeg har skrevet lidt om programmet og lavet en trin for trin-guide, men det er til en ældre version, så der er sikkert sket ændringer siden da:
http://kimludvigsen.dk/programmer-internet-jalbum.php

JAlbum er meget nemmere end at lave et album i hånden, og programmet laver automatisk miniaturebilleder og sider til de store billeder.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » tirs 10. aug 2010 20:17

Hej Kim.

Jeg er meget glad for at du vil hjælpe mig med hjemmesiden.

Jeg ved ikke om i kan se siden sådan her, har aldrig prøvet at lægger en prøveside ud på nettet????????
file:///C:/Documents%20and%20Settings/Mike%20Schmidt%20Harritz/Skrivebord/1-1-2-1-rund-alternativ/index.html

Jeg skal have 4 menupunkter/sider mere.

MVH. Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » ons 11. aug 2010 16:21

Nej, vi kan ikke se siden, når den ligger på din egen computer. Du skal have fat i et webhotel, hvor du så kan uploade siden. Du skal alligevel bruge et webhotel, når du er færdig, så du kan lige så godt bide i det sure æble og bestille det med det samme.

Men jeg kan så forstå, at du bruger min skabelon, og at det er en vandret menu, du vil have. Den har i forvejen 5 menupunkter, så med 4 mere, vil du komme op på 9 menupunkter. Og det er måske lidt for mange i en vandret menu. Generelt skal man undgå for mange menupunkter, for ikke at den besøgende skal miste overblikket, men i dette tilfælde vil du nok også få et pladsproblem.

Men det er forholdsvis nemt at tilføje dem. Du kan finde en anvisning på den oprindelige skabelon, som du kan se her:
http://kimludvigsen.dk/libris/kompozer/ ... /index.php

Med 9 menupunkter skal du så bare angive procentsatsen til 11.1 i stedet for de 16.67 i mit eksempel til 6 menupunkter.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » ons 11. aug 2010 20:04

Hej Kim.

Jeg har fundet en løsning og er nu på rette vej igen!

Jeg har et webhotel som er web10, jeg skal have hjemmesiden over på web10 om senest 4 dage så jeg vil gerne have af vide nu hvordan jeg får den derover?

Jeg har også et andet spørgsmål som er meget enkelt når jeg har arbejdet på fx. min forside og gerne vil videre til næste side fx. hvem er jeg, hvordan kommer jeg over på den???

MVH. Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » ons 11. aug 2010 20:21

Du kan bruge KompoZer til at overføre siden, men det er muligvis ikke den bedste løsning. KompoZers svage punkt er ftp-funktionen, der overfører sider.

Et alternativ er at bruge et selvstændigt ftp-program eller simpelthen at oprette et netværkssted, som så åbnes som en almindelig mappe, hvor du kan overføre filerne ved at trække dem med musen.

Hvis du har mit hæfte, kan du læse om dette på side 41, eller du kan læse denne side:
http://kimludvigsen.dk/programmer-inter ... anager.php

Når du skal lave den næste side, så indlæser du blot den første side. Du skal så STRAKS gemme den under et andet navn via Filer => Gem som. Dermed oprettes en ny side, og du undgår at få overskrevet den første side.

Du har nu en side med menuen, og alt det overordnede på plads, så nu skal du blot udskifte selve indholdet med indholdet på den næste side.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » ons 11. aug 2010 20:41

Okay.

Det med overførslen ser jeg på imorgen eller fredag, men det med at skifte side forstår jeg ikke.

Når jeg nu fx står på forsiden og vil skrive noget under den menu som hedder hvem er vi.
Jeg ved ikke hvad du mener når du skriver at jeg skal indlæse den første side hvad er det for en første side. skal jeg gå op i åbn ny fil eller skal jeg vælge ny?

/Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » ons 11. aug 2010 23:07

Du skal først lave forsiden, og den skal sikkert hedde "index.html". Når du er færdig med den, så indlæser du atter siden i KompoZer.

Klik så på menupunktet Filer => Gem som => og gem filen med et andet navn, fx "hvem-er-vi.html". Dette er et meget vigtigt punkt! Du har nu fået oprettet en kopi af forsiden men med det nye navn. Husk at hvem er vi-linket i menuen skal pege på "hvem-er-vi.html".

Du skal nu slette den tekst og de billeder, der ikke skal være på den nye side, mens du beholder menuen og andre ting, der netop skal være på den nye side. Og så skriver du den tekst og indsætter de billeder, der skal være på hvem er vi-siden. Til sidst gemmer du filen igen ved at klikke på Gem-knappen i værktøjslinjen. Du har nu to sider, forsiden (index.html) og hvem er vi-siden (hvem-er-vi.html).

Til sidst uploader du siderne til serveren.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » tors 12. aug 2010 13:31

Hej Kim.

Okay, men jeg forstår ikke det med at hvem er vi-linket i menuen skal pege på "hvem-er-vi.html".
Fordi Når jeg så har indlæst siden igen står den jo på forsiden, når den gør det skal jeg så gå op i Filer -> gem som -> og gemmer som navnet "hvem-er-vi.html"
kommer den så over på "hvem er vi" siden eller??


Et andet problem jeg åbnede min kompozer og indlæste filen og lige pludselig så det ud som om jeg ikke har brugt en skabelon altså at der bare var en hvid baggrund??


Hilsen Mike

PS. Skal have lavet hjemmsiden færdig inden for de næste 3 dage så hvis du har tid må du gerne svare hurtigt.

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » tors 12. aug 2010 20:21

Kim.

Jeg har fundet ud af det med at lave forskellige sider. :)

Jeg har bare stadig problemet med at jeg åbnede min kompozer og indlæste filen og lige pludselig så det ud som om jeg ikke har brugt en skabelon altså at der bare var en hvid baggrund, og det stod i et "rod"??


MH. Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » fre 13. aug 2010 09:03

ezstreet skrev: Jeg har fundet ud af det med at lave forskellige sider. :)


Fint!

ezstreet skrev: Jeg har bare stadig problemet med at jeg åbnede min kompozer og indlæste filen og lige pludselig så det ud som om jeg ikke har brugt en skabelon altså at der bare var en hvid baggrund, og det stod i et "rod"??


Sker det hver gang? Jeg kan forestille mig, at det er css-filen (stilarket), der ikke indlæses. Hvis du gemmer den nye side i samme mappe som den første side, bør problemet ikke opstå.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » fre 13. aug 2010 14:34

Kim.

Det er begge sider det sker på jeg har jo bare gemt dem der hvor jeg altid har gjort i 1-1-2-1-rund-alternativ mappen hvor stilarket også er???


Hilsen Mike

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » fre 13. aug 2010 14:40

Jeg har prøvet at åbne stilarket i notesblok, kan det passe det eneste der skal stå der i er:: /* Generated by KompoZer */
????

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » fre 13. aug 2010 14:47

Hej Kim.

Har fundet ud af det, jeg tog bare og hentede skabelonen igen og kopierede stilarken over så nu er det godt igen:)


Hilsen Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » fre 13. aug 2010 15:20

Du må have fået slettet indholdet i stilarket på en eller anden måde. Smukt, at du selv fandt en løsning!
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » fre 13. aug 2010 20:01

Hej Kim.

Jeg har nu lavet hjemmesiden og mangler kun fotogalleri og at ligge den på nettet.

Ang. fotogalleri, så har jeg downloaded Jalbum og lavet et galleri men jeg ved ikke hvordan jeg får galleriet over på min hjemmeside under siden "Galleri" ???

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » fre 13. aug 2010 21:44

Kim.

Jeg forklare dig det lige, på web10 som er mit (min fars) webhotel har vi allerede en hjemmeside www.pro-touring.dk grunden til at jeg har lavet en var fordi jeg ville have en bedre og fordi jeg ikke var tilfreds med den som vi havde lavet på web10's website builder. Vores gamle hjemmeside er jo stadig oppe som du kan se, og nu vil jeg så gerne have den nye over på web10 i stedet for den gamle. Hvordan skal jeg gøre det? Slette den gamle på en måde og lægge den nye over? ved du noget om det?.

Med fotoalbummet har jeg fundet ud af at jeg nok først skal offentlige gøre den på hjemmesiden når den er blevet online (altså den nye) ???

Det hele er klar, jeg skal bare have den nye hjemmeside over på web10 og derefter fotoalbummet over..


/Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » fre 13. aug 2010 22:31

Der er lige et par ting, du skal være opmærksom på. Hvis du benytter nogle andre filnavne til de nye sider, så vil søgemaskinerne stadig pege på de gamle sider i et stykke tid. Det vil så enten resultere i, at de besøgende får en fejl, eller at de får vist en gammel side i stedet for den nye.

Hvis du benytter samme filnavne, skal du reelt bare overføre de nye sider, så bliver de gamle automatisk overskrevet. Du kan overføre via KompoZer, men den funktion i KompoZer er fejlbehæftet, så det er nok bedre at bruge et FTP-program eller at bruge et netværkssted. tjek denne side med hensyn til sidstnævnte:
http://kimludvigsen.dk/programmer-inter ... .php#mappe

Du skulle sagtens kunne overføre albummet inden, du overfører de nye sider. Du skal bruge nogle oplysninger for at kunne overføre såvel de nye sider som albummet:
FTP-serverens adresse (typisk noget i stil med ftp://ftpserver.dk)
Brugernavn
Adgangskode

JAlbum har et indbygget FTP-program, som du bør bruge til at overføre albummet med.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » lør 14. aug 2010 09:20

Hej Kim..

Inden jeg kan prøve alt dette, skal jeg have rettet et meget meget irriterende problem!

Hver efter at jeg har fået lavet siderne færdig, og tilføjet billeder på de forskellige sider (som du også kan se på den gamle hjemmeside) er den begyndt med ikke at kunne vise billederne, fks. Nu da jeg åbnede den i dag var der en lille rød prik oppe i venstre hjørne!??

MVH. Mike

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » lør 14. aug 2010 09:24

Hej Kim..

Angående det med siderne skal passe overens med navnene så har jeg ikke alle de gamle sider med jeg har kun: Home, 25.2 camaro, street camaro, hvem er vi, karting, 4 sale og galleri.

Men inden jeg kan prøve alt dette har jeg fået et meget irriterende problem!

Hver gang efter at jeg har fået lavet siderne færdig, og tilføjet billeder på de forskellige sider (som du også kan se på den gamle hjemmeside) er den begyndt med ikke at kunne vise billederne, fks. Nu da jeg åbnede den i dag var der en lille rød prik oppe i venstre hjørne af billderne!??

MVH. Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » lør 14. aug 2010 13:55

Den røde prik vises, hvis et billede ikke kan findes. Det kan skyldes, at billedet ikke ligger på serveren, eller at der var problemer med forbindelsen til serveren. Som regel skyldes det førstnævnte, men hvis billedet plejer at være der, så er det nok sidstnævnte.

Umiddelbart kan jeg ikke se, at der skulle mangle billeder på siderne. Kan du fortælle, hvilken side du mangler billeder på, og hvilke billeder der mangler?

Jeg kan se, du vil løbe ind i det tidligere nævnte problem med forskellige filnavne. Det vil sige, at hvis nogle har bogmærket en side, vil de havne på den gamle side. Og søgetjenesterne vil i en periode henvise til den gamle side.

Hertil kommer, at det sandsynligvis ikke vil virke, hvis du bare uploader de nye sider. Den gamle forside hedder index.php, og på mange servere vælges index.php før index.html, som din nye side sikkert hedder.

Den nemmeste løsning er at slette alle de gamle sider og så uploade de nye sider. Det giver dig problemer med bogmærker og søgetjenester i en periode.

Alternativ 1: Tjek, om der er mulighed for at lave viderestilling i webhotellets hjemmesideprogram. I så fald kan du viderestille index.php til index.html, og ditto med de andre sider til de nye sider.

Alternativ 2: Du kan omdøbe de nye sider til det samme som de gamle. Dette kan dog være lidt nørdet, afhængig af, hvordan det er lavet. Det er ikke noget, jeg umiddelbart kan gennemskue, fordi der er brugt php. Det kræver, at man har ftp-adgang til serveren, så man kan se de reelle filnavne og placeringer.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » lør 14. aug 2010 14:13

Hej Kim.

Det prøver jeg at se på!

Angående billederne er det ikke dem der er på den gamle hjemmeside, men dem som er på kompozer, de billeder kan den så ikke finde. Dette forstår jeg ikke da alle billederne ligger på min computer .?
Kan det være noget med at nogle af dem er hentet fra nettet?

Hilsen Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » lør 14. aug 2010 14:27

Når de er den nye side, så kan det være på grund af forkerte henvisninger til billederne eller en forkert placering. Jeg har desværre ikke mulighed for at sige, hvilket er tilfældet, uden at kunne se dem.

Hvis du ikke selv får løst problemet, kan du evt. prøve at lægge siderne og billederne op på webhotellet, så jeg kan se dem. Du kan evt. oprette en ny mappe på webhotellet med navnet test, og så placere det hele der. Så vil de gamle sider stadig virke, og det vil være muligt at finde evt. fejl i de nye sider.
Mvh. Kim

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » lør 14. aug 2010 16:38

Okay, denne gang jeg åbnede kompozer så jeg at billederne stadig ikke var der men der var et andet ikon denne gang! Det ikon som er kommet er det der bliver vist hvis billedet er i stykker.?

Hvis jeg ikke får løst problemet prøver jeg at lave en "test mappe" som du siger.


/Mike

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » lør 14. aug 2010 20:45

Hej Kim.

Jeg har fundet problemet med billederne:)

-Mike

ezstreet
 

Re: Nyt spørgsmål

Indlægaf ezstreet » søn 22. aug 2010 13:19

Hej Kim.

Jeg har nu fået lavet hjemmesiden færdig og har flyttet den over på webhotellet i ftp mappen. Jeg gjorde det ved hjælp af din guide til "Opret en mappe med dit webhotel"

Nu ved jeg så bare ikke hvad jeg gør nu, fordi hjemmesiden er jo ikke blevet offentliggjort, den ligger jo bare på webhotellet, men er ikke kommet på nettet, sådan at andre end mig selv har adgang til at kunne se den.

Ved du noget om hvordan man offentliggøre den??

MH Mike

Kim Ludvigsen
MozillaDanmark
 
Indlæg: 11317
Tilmeldt: lør 5. mar 2005 21:45

Re: Nyt spørgsmål

Indlægaf Kim Ludvigsen » søn 22. aug 2010 14:32

Du har muligvis fået placeret filerne i en forkert mappe. Hvis du placerer filerne i den rigtige mappe, bør det virke helt automatisk.
Mvh. Kim