Fejl i forummet

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 3801
Tilmeldt: fre 28. dec 2007 17:40
Geografisk sted: Aarhus

Fejl i forummet

Indlægaf Jørgen Rasmussen » søn 3. mar 2013 19:36

Feedet rss.php opdateres ikke længere.

Kode: Vælg altFejl: ikke well-formed
Kildefil: http://forum.mozilladanmark.dk/rss.php
Linje: 51, Kolonne: 327
Kildekode:
  <summary type="html">Har lavet alle mine email konti om til Imap i stedet for pop3. Fint og praktisk, når man arbejder fra flere computerere. Under mig bare at &amp;quot;sendt&amp;quot;, &amp;quot;kladde&amp;quot;, &amp;quot;spam&amp;quot; og &amp;quot;papirkurv&amp;quot; ligger som undermapper under Indbakken? Skal de det����? Da jeg havde pop3  lå de jo på niveau med Indbakken, hvilket også forekommer mere normalt. Kan jeg få dem derud igen, altså så de ligger på niveau med indbakken, og ikke som undermapper til denne?&lt;br /&gt;&lt;br /&gt;&lt;span style=&quot;font-size: 80%; line-height: 116%;&quot;&gt;&lt;span style=&quot;color: gray&quot;&gt;Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.97 Safari/537.22&lt;/span&gt;&lt;/span&gt;</summary>


Vi skal have fjernet de ulovlige tegn.

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:19.0) Gecko/20100101 Firefox/19.0
Hilsen Jørgen

Double-G
 
Indlæg: 401
Tilmeldt: ons 14. sep 2005 21:05

Re: Fejl i forummet

Indlægaf Double-G » søn 3. mar 2013 20:17

feed.php virker fint og validerer (med ganske få anbefalede ændringer)

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 3801
Tilmeldt: fre 28. dec 2007 17:40
Geografisk sted: Aarhus

Re: Fejl i forummet

Indlægaf Jørgen Rasmussen » søn 3. mar 2013 20:55

Når jeg tjekker på WC3 Feed Validation Service står der på siden:
Sorry

This feed does not validate.
Hilsen Jørgen

Double-G
 
Indlæg: 401
Tilmeldt: ons 14. sep 2005 21:05

Re: Fejl i forummet

Indlægaf Double-G » søn 3. mar 2013 21:00

Ja den melder fejl til

rss.php

men This is a valid Atom 1.0 feed. til

feed.php

og det er feed.php der dukker ved rss søgning

Jesper Kristensen
MozillaDanmark
 
Indlæg: 6461
Tilmeldt: lør 26. feb 2005 12:27
Geografisk sted: København

Re: Fejl i forummet

Indlægaf Jesper Kristensen » søn 3. mar 2013 21:15

Rettet. Jeg tilføjede følgende til koden:
$text = iconv("UTF-8","UTF-8//IGNORE",$text);

Fra https://blog.liip.ch/archive/2005/01/24 ... cters.html

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 3801
Tilmeldt: fre 28. dec 2007 17:40
Geografisk sted: Aarhus

Re: Fejl i forummet

Indlægaf Jørgen Rasmussen » søn 3. mar 2013 21:22

Tak Jesper

Nu fungerer det i Thunderbird igen.
Hilsen Jørgen