Side 1 af 1

Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 18:39
af DKCPH
Hej

Jeg håber at der der én eller flere superbrugere derude, som forhåbentlig kan hjælpe med at løse mit problem.

Der er flere add-ons som jeg gerne vil tilføje, men hvor jeg får fejlen:
"This add-on requires a newer version of Firefox (at least version 56.0). You are using Firefox 52.0."


Jeg har dog imidlertid seneste version af Mozilla installeret: 59.0.2 (64-bit). Der er vedhæftet et billede af problemet til dette indlæg.

Hvad gør jeg for, at den finder ud af, at jeg faktisk har seneste version? Jeg oplever det både med det konkrete viste add-on samt flere af de add-ons som Mozilla/Firefox selv fremstiller.

/DKCPH

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 18:55
af Kim Ludvigsen
Hej DKCPH

Problemet er, at du bruger en forældet Windows. Den nyeste version af Firefox er 59, men den kan ikke køre på Windows XP. Din Firefox 52 er den nyeste, der kan køre på XP, men den Firefox er så gammel, at der er mange udvidelser, der ikke kan køre på den.

Du kan læse mere her:
https://support.mozilla.org/da/kb/ophoe ... p-og-vista

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 18:59
af DKCPH
Hej Kim

Tak for dit hurtige svar.

Jeg har aldrig haft andet end Windows 10 installeret på denne maskine.

/DKCPH

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 19:01
af DKCPH
DKCPH skrev: Hej Kim

Tak for dit hurtige svar.

Jeg har aldrig haft andet end Windows 10 installeret på denne maskine.

/DKCPH


Btw. har jeg Firefox version 59.0.2 installeret - skulle også fremgå af både tekst og billede :-)

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 19:31
af ojunker
Hej DKCPH
Der er altså noget der ikke stemmer.

Den User agent string, der er anført over dit indlagte billede, angiver altså, at dit indlæg er afsendt fra en maskine, der kører Windows 7 og anvender Firefox 52.0
Se følgende:
"Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0"

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 19:52
af Jørgen Rasmussen
Kontroller lige om du har en fil med navnet user.js i Firefox' profilmappe:
Klik på menuknappen og vælg Hjælp -> Teknisk information. Søg efter Indstillinger i user.js på siden 'Teknisk information'. (Du kan åbne søgebjælken med tastaturgenvejen Ctrl+F.)

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 21:12
af DKCPH
ojunker skrev: "Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0"


Hmm, det forstår jeg ikke. Anvender en bærbar med Windows 10 Home. Hvis jeg går op i menuen: "Hjælp" --> "Om Firefox", hvor den søger efter nye opdateringer, viser den også version 59.0.2.

Jørgen Rasmussen skrev: Kontroller lige om du har en fil med navnet user.js i Firefox' profilmappe:
Klik på menuknappen og vælg Hjælp -> Teknisk information. Søg efter Indstillinger i user.js på siden 'Teknisk information'. (Du kan åbne søgebjælken med tastaturgenvejen Ctrl+F.)


Jeg kan ikke se at jeg har filen "user.js" i mappen. Jeg har uploadet et nyt billede til dette indlæg, som viser indstillingerne.

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 21:21
af Jørgen Rasmussen
Måske er det en udvidelse, der laver ravage. Prøv at starte Firefox i fejlsikret tilstand, og se om det hjælper. (Hold skift-tasten nede mens du starter Firefox.)

Hvis det ikke hjælper, så skriv about:config i adressefeltet, og tryk på Enter-tasten. Klik på knappen 'Jeg lover at være forsigtig!'. Søg efter privacy.resistFingerprinting ved hjælp af søgefeltet på siden about:config. Kontroller om indstillingens værdi er sat til false. Hvis den ikke er false, så dobbeltklik på true, så værdien ændres til false.

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 21:32
af DKCPH
Jørgen Rasmussen skrev: Hvis det ikke hjælper, så skriv about:config i adressefeltet, og tryk på Enter-tasten. Klik på knappen 'Jeg lover at være forsigtig!'. Søg efter privacy.resistFingerprinting ved hjælp af søgefeltet på siden about:config. Kontroller om indstillingens værdi er sat til false. Hvis den ikke er false, så dobbeltklik på true, så værdien ændres til false.


Wow, det virkede! Tak! Nu kan jeg installere de add-ons, som jeg ikke før kunne installere (fordi Firefox mente, at jeg anvendte en ældre version).

Nu er jeg lidt nysgerrig Jørgen, om hvad privacy.resistFingerprinting indeholder? En ændring af denne betyder vel, at min browser efterlader et unikt fingerprint til hjemmesider jeg besøger? Men så kan jeg bare ændre den tilbage igen, når jeg har installeret de add-ons jeg skal bruge. Skal jeg så senere bruge et igen, så må jeg lige slå det fra mens jeg henter.

Re: Add-on kræver nyere version - men har den nyeste

Indlæg: ons 25. apr 2018 21:54
af Jørgen Rasmussen
Indstillingen er som standard sat til false. Enten har du eller en udvidelse, du har installeret, ændret værdien.
Jeg ved ikke rigtigt noget om indstillingen, men den ændrer bl.a Firefox' User Agent, så den viser den seneste Firefox ESR-version, som pt er 52.0. Når du opdaterer Firefox til version 60.0 (som er en ESR-version) vil Firefox' User Agent vise, at den er version 60.
Du kan læse mere her: https://wiki.mozilla.org/Security/Fingerprinting