Firefox » Websider viser undefined

Gæst Aarhus
 

Websider viser undefined

Indlægaf Gæst Aarhus » tors 9. apr 2020 16:12

Nogle websider er begyndt at vise "undefined" når jeg åbner dem i Firefox. Et kort øjeblik ser jeg siden, der så skifter til blank side med teksten "undefined".

Feks. http://www.lundskov.dk/kongehus, eller https://lundskov.dk/kongehus.

Når jeg kigger på kildekoden vises kun "<span>undefined</span>" og linket som "view-source:wyciwyg://2/https://www.lundskov.dk/kongehus/

Siden kan godt åbnes normalt i fx Google browseren.

Mvh Konrad

Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 5454
Tilmeldt: fre 28. dec 2007 17:40
Geografisk sted: Aarhus

Re: Websider viser undefined

Indlægaf Jørgen Rasmussen » tors 9. apr 2020 16:40

Hej Konrad

Jeg ved ikke, hvad der er galt.

Det kan være en udvidelse, der driller. Prøv at starte Firefox i fejlsikret tilstand for at se, om det hjælper. https://support.mozilla.org/da/kb/loes- ... t-tilstand

Du kan også prøve at rydde Firefox' cache og genstarte Firefox. https://support.mozilla.org/da/kb/saada ... efox-cache

Er det med vilje, at du bruger en ældre og usikker version af Firefox?
Hilsen Jørgen

Gæst Aarhus
 

Re: Websider viser undefined

Indlægaf Gæst Aarhus » tors 9. apr 2020 17:00

Hej Jørgen.

Bruger (meget)gammel FF56, da nogle af mine tilføjelser ikke virker i nyere versioner.

Har prøvet i fejlsikret tilstand, samme problem.
Har også nu prøvet i en ren FF75 uden tilføjelser, samme problem.

Hvis du, Jørgen, åbner siden får du så samme fejl?
https://www.lundskov.dk/kongehus/

Gæst Aarhus
 

Re: Websider viser undefined

Indlægaf Gæst Aarhus » tors 9. apr 2020 17:07

Det mest mystiske ved det er, at fejlen opstår når jeg besøger siden 1. gang.

Når jeg genindtaster sideadressen, uden at have lukket browseren - og uden at have ryddet historikker (cachen) - fremkommer fejlen ikke, og siden åbner normalt.

Jørgen Rasmussen
MozillaDanmark
 
Indlæg: 5454
Tilmeldt: fre 28. dec 2007 17:40
Geografisk sted: Aarhus

Re: Websider viser undefined

Indlægaf Jørgen Rasmussen » tors 9. apr 2020 17:27

Da jeg skrev mit første svar, kunne jeg ikke genskabe dit problem. Herefter deaktiverede jeg sporingsbeskyttelsen i min Firefox, slettede noget websiden havde hentet, og genindlæste siden. Herefter får jeg en hvid side med teksten "undefined".

Nederst på siden findes en tæller fra statcounter.com. Det ser ud til, at det er koden til den, der fremkalder problemet.
Hilsen Jørgen

Gæst Aarhus
 

Re: Websider viser undefined

Indlægaf Gæst Aarhus » tors 9. apr 2020 17:36

Meget mystisk, når jeg åbner nævnte side i Privat browsing, opstår fejlen ikke.

Måske har du ret I det kan være noget med statcounter.

Kan se at andre åbenbart har haft tilsvarende problemer helt tilbage i 2010 på en denne side: https://support.mozilla.org/en-US/questions/699151

Mvh Konrad